Tampilkan postingan dengan label Mikrotik. Tampilkan semua postingan
Tampilkan postingan dengan label Mikrotik. Tampilkan semua postingan

Rabu, 26 Oktober 2016

Cara memonitor perangkat jaringan (Router, Switch, Server, dll), jika ada perubahan status perangkat misal dari up ke down dan sebaliknya maka akan ada notifikasi SMS yang masuk ke HP Anda. Hal ini bisa kita lakukan dengan bantuan Aplikasi monitoring jaringan Gratis buatan Mikrotik, yaitu The Dude.

Apa itu The Dude? Bagaimana Cara Install The Dude? Silakan baca artikel sebelumnya tentang The Dude Mikrotik :

Dari sini saya anggap Anda sudah bisa menginstall The Dude dan sudah membuat Network Map sesuai topologi jaringan Anda. Mulai dari sini kita akan langsung masuk ke Tutorial Cara Membuat Notifikasi SMS pada Aplikasi The Dude.

Apa saja yang perlu kita siapkan?

1. Aplikasi The Dude yang sudah terinstall dan siap digunakan (Bisa pakai versi lama atau baru)
2. Modem USB, untuk mengirim SMS
3. Aplikasi Plink SSH, untuk mengirim command dari The Dude ke Mikrotik via SSH

Langkah pertama 

Menginstall Modem USB di Mikrotik untuk mengirim SMS. Caranya sudah pernah saya bahas disini :

Langkah kedua

Membuat user dummy di Mikrotik yang akan digunakan untuk mengirim command SMS ke Mikrotik.
Silakan buat user baru dengan role/Group write.


Langkah ketiga

Copy plink.exe ke direktori c:\plink


Langkah keempat

Membuat notifikasi baru di The Dude. Buka The Dude --> Masuk ke menu Notifications --> Buat Notifikasi bar --> beri nama notifikasi nya misal "SMS Notification" --> centang Enabled --> Pilih type : execute locally

Pada kolom Command isikan script dengan format sebagai berikut :

C:\plink\plink.exe -ssh -l mikrotik_sms_username -pw mikrotik_sms_password mikrotik_sms_ipaddress "/tool sms send phone-number=nomorhpanda usbportnumber message=\"[Probe.Name] on [Device.Name] is now [Service.Status]\""



Langkah kelima

Terapkan (apply) notifikasi yang sudah dibuat ke Network Map yang ingin kita pantau perangkat nya. Masuk ke Network Map yang diinginkan --> klik menu Settings --> Masuk ke tab Polling --> centang Use Notifications --> centang SMS Notification.


Langkah keenam

Tes konfgurasi nya dengan mencoba meng-offline-kan (meng-down-kan) perangkat yang dimonitor. Jika Konfigurasi sudah benar, maka akan ada notifikasi SMS yang masuk ke HP Anda.

Langkah ketujuh

Dari contoh hasil notifikasi di atas ada 2 perangkat yang down, tapi notifikasi SMS yang masuk ada 10 SMS. Jika notifikasi yang masuk dirasa terlalu banyak, kita bisa kurangi hanya 1 SMS saya per perangkat, yaitu dengan hanya mengaktifkan service ping pada tiap perangkat yang dimonitor.
Caranya dengan dobel klik ke masing-masing perangkat --> Masuk ke tab Services --> Hapus semua service nya kecuali ping, atau sesuai keinginan Anda.


Selesai sudah Tutorial Cara Membuat Notifikasi SMS pada Aplikasi The Dude. Jika perangkat yang Anda Monitor sangat banyak, Anda bisa coba kolaborasikan dengan Notifikasi Email The Dude, caranya sudah pernah saya bahas disini :

Jika Tutorial Mikrotik ini dirasa kurang jelas, silakan Anda tonton video presentasi saya pada saat Mikrotik User Meeting (MUM) Indonesia 2016 di Jakarta berikut ini :

Cara Membuat Notifikasi SMS The Dude (Aplikasi Monitoring Jaringan)


Anda juga bisa download file Presentasi MUM ID 2016 saya disini :

Oke, selamat mencoba dan semoga bermanfaat :)

Rabu, 03 Agustus 2016

Selamat Siang pada artikel kali ini saya akan membahas tentang setting point to multipoint, sebelumnya pasti teman-teman sudah tau perbedaan antara point to point dengan point to multipoint, ijinkan saya mengulangi lagi point to point berarti satu point ke point lawannya sedangkan point to multipoint yaitu satu point ke banyak point yang bisa terhubung.

Pengerian PTMP

pengertian point to multipoint menurut wikipedia yaitu komunikasi yang dilakukan melalui tipe yang berbeda dari satu ke banyak koneksi, Point-to-multipoint yang paling banyak digunakan di Internet nirkabel (Wireless) dan IP telephony melalui frequency radio. Point-to-Multipoint juga sering disingkat P2MP, PTMP atau PMP.

Bahan yang disiapkan

dalam tutorial ini alat yang saya gunakan sebagai berikut:
Router Gateway:
  • RB750
Router sebagai AccesPoint :
  • RB411AH lengkap beserta (Minipci:XR5, Pigtail, Jumper Panel, Horn Besar, Box, Adaptor 3A, Poe)
  • Kabel Lan 
  • Antena Grid 24 dB
Untuk Client sebagai Station :
  • Groove lengkap beserta adaptor dan poe
  • Horn kecil
Untuk Client2 sebagai Station :
  • Groove lengkap beserta adaptor dan poe
  • Horn kecil

Topologi 



pada topologi di atas ada dua groove yang satu mendapatkan ip dari routerboard 750 dan yang satu nya dari RB411AH saya sengaja menggunakan kedua cara ini apabila ada kesalahan mohon bimbingannya :)

Ada 4 router yang akan kita konfigurasi berikut langkahnya

Konfigurasi Routerboard 750




Langkah pertama yang saya lakukan seperti gambar diatas, yaitu membuat rb750 bisa terkoneksi internet
  1. masukkan ip address (ether1:Internet, ether3:Local ada 2 ip )
  2. berikan ip dns 
  3. beri routing static
  4. cek ping google.com
  5. beri kan firewall agar bisa diakses mikrotik station

Konfigurasi RB411AH

  •  Pertama yaitu kita setting Bridge pada Port wlan1 dan ether1

  • Kita Setting Wireless

Mode                 : AP Bridge
Frequency          : (Tentukan)
SSID                  : (Tentukan)
Radio Name       : (Tentukan)


pada tab WDS
WDS Mode : Dynamic
WDS Default Bridge : (Bridge yg dibuat tadi)


Setting Ip addres, dns dan static route



Konfigurasi Groove (ip dari rb750)

Isi Frequency, dan scan list di rb411AH kemudian klik scan, dan Connect


ganti mode dengan station wds, tentukan radio name


pada tap WDS, WDS mode :Dynamic

Kita masukkan ip yg kita buat di rb750 tadi, masukan dns, dan static route, dan cek ping google atau etc

Konfigurasi Groove (ip dari RB411AH)

 Setting mode, frequency=rb411ah, scan list : antara frequency rb411ah


Tap WDS: Dynamic
wds default bridge : none

Kita dhcp client, sebelumnya dhcp server terlebih dahulu pada ether wlan di rb411AH, Setelah bound maka cek ping ke internet



beri ip address, sesuai gambar diatas, kemudian beri ip firewall nat agar ip local tersebut diubah seakan-akan ip publik yg sedang berselancar di google /internet, jika tidak anda dhcp server, maka beri ip static pada komputer/laptop anda


Ok selesai,
Jika ada kesalahan saya mohon maaf, dan mohon bimbingannya, ^_^


Minggu, 31 Juli 2016

Modem WiFi (MiFi) Smartfren Andromax merupakan Modem WiFi multifungsi yang dijual oleh Smartfren dimana bisa langsung digunakan oleh user, baik menggunakan WiFi maupun USB sebagai modem 4G LTE. Namun fitur yang ada dalam Andromax sendiri cukup terbatas, dimana hanya mampu digunakan untuk maksimal 32 user dan tidak ada management user, dan management bandwidth nya. Jadi kalo dipakai rame-rame bakalan rebutan bandwidth kan?

Tapi, kenapa harus pakai Smartfren Andromax? kenapa gak pakai Modem 4G lain aja? Jawabannya simpel, karena Smartfren lagi promo dimana beli Andromax bisa dapat Quota lumayan besar, yakni 30GB. Mantap kan? Hehe

Membuat MiFi Andromax Jadi Hotspot Mikrotik


Modem WiFi (MiFi) Smartfren Andromax dapat digunakan pada Mikrotik. Ada beberapa tipe MiFi Andromax yang beredar di pasaran, namun tidak semua tipe bisa dikenali oleh Mikrotik. Salah satu Tipe Andromax yang bisa dikenali dan digunakan pada Mikrotik adalah Andromax M2P.

Setting Modem WiFi Smartfren Andromax M2P

1. Sambungkan Kabel USB Andromax M2P ke PC/laptop --> Install Aplikasi nya
2. Buka Browser --> Masukkan IP Address MiFi nya --> 192.168.8.1
3. Login ke Managemen Web Andromax dengan user default (jika belum dirubah) user & pass : admin

MiFi Andromax dijadikan Hotspot Mikrotik

4. Pilih menu Settings

Modem WiFi Andromax Hotspot Mikrotik


5. Masuk kemu Dial-up --> Mobile Connection --> Connection mode pilih Auto --> Apply

Andromax M2P jadi Modem WiFi Mikrotik Hotspot

6. Masuk menu WLAN Basic Settings --> SSID Broadcast pilih Disable.

Smartfren Andromax M2P Modem Mikrotik

7. Masuk ke tab Connection --> Pastikan Andromax sudak konek ke jaringan 4G LTE.

Konek MiFi Andromax ke Mikrotik

Setting Mikrotik RB951Ui-2HnD

1. Sambungkan Kabel USB Andromax ke port USB Mikrotik RB951Ui-2HnD
2. Login ke Mikrotk RB951Ui-2HnD via Winbox
3. Masuk ke menu Interface --> LTE. Pastikan interface LTE dari Andromax sudah ter-install dan muncul di list. Jika tidak, coba reboot Mikrotik nya dan cek port USB nya pada menu System --> Resources --> USB
Setting MiFi Andromax di Mikrotik

4. Jika Interface LTE sudah muncul, dia akan langsung konek ke jaringan LTE tanpa perlu seting lagi. Tinggal kita ganti nama nya saja menjadi ANDROMAX.

Cara Setting Andromax jadi Modem Mikrotik

5. Buat DHCP Client supaya Mikrotk mendapat IP Address dari Andromax. IP --> DHCP client --> Add -> Interface pilih LTE nya Andromax, sesuai gambar di atas.

6. Jangan lupa buat kan rule NAT Masquerade pada IP --> Firewall --> NAT

Andromax jadi modem Mikrotik Hotspot

7. Jika kita ingin share koneksi internet nya via WiFi, aktifkan dulu interface wlan1 nya, silakan setting sesuai keinginan.

8. Membuat Hotspot Mikrotik menggunakan MiFi Andromax bisa kita lakukan sekarang. Silakan gunakan Hotspot Wizard dengan interface yang digunakan LTE Andromax. 

9. Kita juga bisa melakukan Manajemen Bandwidth MiFi Smartfren Andromax dengan memanfaatkan Queue Mikrotik. 

10. Sekarang penggunaan MiFi Smartfren Andromax M2P bisa lebih optimal dengan bantuan Mikrotik :)

Perlu diketahui bahwa tidak semua Modem WiFi Andromax bisa dikenali oleh Mikrotik, hanya tipe-tipe tertentu saja yang menggunakan Chipset Huawei, seperti Andromax M2P. Sementara untuk tipe lain yang menggunakan Chipset baru Qualcomm MDM 9307 hingga artikel ini di buat belum bisa dikenali oleh Mikrotik. Tipe MiFi yang belum support Mikrotik yaitu :
  • Andromax M3Y
  • Andromax M3Z
  • Andromax M2S
  • Andromax M2Y
  • dll
Jadi saya sarankan untuk menggunakan Andromax tipe M2P seperti yang saya gunakan pada artikel ini.

Kamis, 28 Juli 2016

Membatasi/Limit Bandwidth pada Hotspot Mikrotik merupakan hal yang sangat perlu dilakukan. Mengingat Wireless Hotspot dapat diakses oleh siapa saja yang memiliki hak akses, sehingga agar terciptanya keadilan dan kesejahteraan yang merata pada segenap user hotspot diperlukan Pembatasan Bandwidth Hotspot Mikrotik.

Metode Pembatasan Bandwidth Hotspot Mikrotik ada 2 :

    - Built-in limiter merupakan metode Limit Bandwidth Hotspot Mikrotik yang menggunakan parameter rate-limit di server-profile untuk melimit total traffic dari jaringan hotspot sedangkan jika ingin limit per user bisa menggunakan rate-limit di user-profile. Built-in Limitation dilakukan secara otomatis dan mudah tetapi tidak memungkinkan melakukan implementasi HTB.
      - Custom limitation merupakan metode Limit Bandwidth Hotspot Mikrotik yang menggunakan parameter Incoming-packet-mark dan outgoingpacket-mark pada user-profile. Dengan menggunakan Custom Limitation anda bisa melakukan implementasi HTB dan melakukan limitasi berdasarkan kriteria koneksi yang lebih beragam. 

        Cara Membatasi/Limit Bandwidth User Hotspot Mikrotik menggunakan Built-in Limiter :

        Rate Limit pada Hotspot Server Profile

        Rate Limit pada Hotspot Server Profile

        Penggunaan Rate Limit pada hotspot server profile ini, secara otomatis akan membatasi total traffic pada jaringan Hotspot Mikrotik. Pada gambar di atas, besarnya rate limit yang diset pada jaringan hotspot adalah sebesar 2M/2M, yang berarti 2 Mbps untuk total traffic upload dan 2 Mbps untuk total traffic Download pada jaringan hotspot tersebut. Perlu diketahui bahwa dengan menggunakan metode ini user yang di bypass melalui IP Binding Hotspot juga ter-limit.

        Rate Limit pada Hotspot User Profile

        Rate Limit pada Hotspot User Profile

        Penggunaan Rate Limit yang pada hotspot user profile ini, akan membatasi total traffic secara otomatis yang bisa dicapai oleh masing-masing client hotspot yang berada pada satu group. Client hotspot yang terhubung dalam jaringan hotspot, mendapatkan total traffic yang bisa dicapai sebesar 512 kbps untuk download dan 512 kbps untuk upload.

        Hasil penggunaan Built-in bandwidth limiter Hotspot Mikrotik


        Cara Membatasi/Limit Bandwidth User Hotspot Mikrotik menggunakan Custom Limitation :


        Parameter Incoming Packet Mark dan Outgoing Packet Mark didefinisikan untuk melakukan penandaan (marking) traffic dari user didalam group tersebut. Incoming Packet Mark melakukan marking traffic upload dan Outgoing Packet Mark melakukan marking traffic download.

        Penggunaan incoming dan Outgoing Packet Mark Hotspot Mikrotik


        Firewall mangle akan terbentuk secara otomatis dan dinamis, dimana bertugas melakukan marking packet traffic dari client yang masuk di dalam group (profile). Dynamic Marking ini dilakukan di chain Hotspot. 

        Mangle rule otomatis terbentuk dari incoming dan outgoing packet mark

        Penambahan Rule Jump dari Built-in Chain ke chain hotspot diperlukan supaya traffic dari user dapat dibaca di firewall.

        /ip firewall mangle add chain=prerouting action=jump jump-target=hotspot
        /ip firewall mangle add chain=postrouting action=jump jump-target=hotspot

        Jika di asumsikan network yang digunakan adalah network NAT. Mark-Connection harus dibuat berdasarkan mark packet dynamic dari profile atau dari chain hotspot.
        /ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=koneksi_hotspot passthrough=yes packetmark=hs1-in

        Selanjutnya Mark-Packet bisa dibuat supaya bisa diimplementasikan atau dilimit trafficnya.
        /ip firewall mangle add chain=prerouting action=mark-packet newpacket-mark=paket_hotspot passthrough=no connectionmark=koneksi_hotspot
        /ip firewall mangle add chain=postrouting action=mark-packet newpacket-mark=paket_hotspot passthrough=no connectionmark=koneksi_hotspot
        Rule Mangle yang digunakan pada Custom Bandwidth Hotspot Mikrotik


        Setelah mark packet dari traffic group1 sudah dibuat maka limitasi bandwidth bisa dibuat di Queue.

        Setting pada Queue Tree

        Membuat Queue Tree untuk Traffic Download global, kita contohkan menggunakan Max Limit 2 Mb.

        Queue Tree Global Download Hotspot Mikrotik

        Kemudian membuat Queue Tree turunan nya khusus untuk download via Hotspot menggunakan Limit At 1 Mb dan Max Limit 2Mb.
         

        Queue Tree Download Hotspot Mikrotik

        Buat Queue Tree yang sama untuk traffic upload nya, sehingga menjadi seperti gambar berikut :

        Hasil Penggunaan Queue Tree pada Hotspot Mikrotik

        Selanjutnya Queue Tree Hotspot Mikrotik ini bisa kita kembangkan untuk membuat managemen bandwidth yang lebih complex, misalnya dengan menggunakan PCQ, dsb.

        Senin, 04 Juli 2016

        Melanjutkan Tutorial Mikrotik Indonesia sebelumnya tentang : Tutorial Cara Membuat Beberapa Hotspot Server pada satu Mikrotik dengan IP Address yang Berbeda. Pada Tutorial kali ini kita akan coba bahas gimana caranya membuat beberapa Halaman Login Mikrotik berbeda yang digunakan pada beberapa Hotspot Server pada 1 Mikrotik.


        Jadi disini saya asumsikan kita punya 1 Mikrotik sebagai Hotspot Server dimana ada 2 Server yang running bersamaan dengan IP Address yang berbeda, seperti pada artikel sebelumnya. Nah, saya ingin membuat kedua Hotspot itu memiliki Halaman Login yang berbeda, walaupun lokasi nya masih di perangkat Mikrotik yang sama.

        Sampai disini sudah paham kan apa yang saya maksud? Kalau belum silakan baca ulang dari atas, hehe.
        Oke, langsung saja berikut cara nya :

        1. Pastikan Anda Sudah Membuat lebih dari 1 Hotspot Server, seperti pada Tutorial Mikrotik sebelumnya.

        2. Siapkan Halaman Login Mikrotik Baru yang akan ditambahkan.

        3. Masuk ke FTP Mikrotik dari Windows Explorer. Ketikkan ftp://ipmikrotik di address bar. Usahakan gunakan IP selain IP untuk hotspot. Kalau bingung, silakan baca : Cara Mengganti Halaman Login Hotspot Mikrotik



        4. Buat Folder baru, beri nama misal : hotspot2

        5. Copy semua file Halaman Login Mikrotik baru yang mau ditambahkan ke folder tersebut.


        6. Selanjutnya, buka Winbox masuk ke Menu IP --> Hotspot --> Server Profiles --> Pilih Hotspot Server Profile nya --> Pada kolom HTML Directory silakan pilih folder yang berisi halaman login mikrotik yang diinginkan.


        7. Buka Server Profile lainnya, Ganti HTML Directory dengan folder Halaman Login Mikrotik yang diinginkan, misal folder hotspot2 yang sebelumnya kita buat.


        8. Sekarang tinggal cek hasilnya. Silakan konek ke WiFi Hotspot masing-masing. Jika setingan sudah benar, maka untuk tiap server hotspor akan menampilkan halaman login hotspot yang berbeda.

        Jadi disini tidak hanya IP Address nya saja yang berbeda pada 2 Hotspot Server tersebut, tetapi kedua Halaman Login Hotspot tersebut juga berbeda.

        Sumber : Microtik Indonesia 

        Rabu, 29 Juni 2016

        Tutorial Cara Membuat Beberapa Hotspot Server pada satu Mikrotik dengan IP Address yang Berbeda. Judul ini mungkin membuat Anda bingung. Jadi maksudnya begini, misalkan kita mau buat Hotspot khusus untuk Ruang Rapat dan Hotspot khusus Karyawan. Kedua nya mau dibedakan IP Address nya, supaya alokasi IP Address nya lebih banyak. Namun kita hanya punya satu Mikrotik yang digunakan untuk running Hotspot Server + User Manager

        Lebih jelasnya bisa dilihat di gambar berikut ini :


        Gambar tersebut saya ambilkan dari Tutorial Mikrotik sebelumnya tentang Cara Membuat Hotspot Mikrotik tanpa Terhubung Langsung ke AP Menggunakan EoIP Tunnel. Jadi disini saya melanjutkan dari tutorial tersebut, saya sarankan untuk membaca nya terlebih dahulu. Disini saya akan contohkan membuat 2 Hotspot Server yang berbeda IP Address pada 1 perangkat Mikrotik.


        1. Buat interface Bridge sebanyak Hotspot yang mau kita buat. Disini saya contohkan membuat 2 Interface Bridge. 


        2. Masukkan interface EoIP untuk ruang rapat dan pegawai sesuai dengan bridge nya.


        3. Tambahkan IP Address untuk masing-masing interface Bridge nya.


        4.  Buat 2 Hotspot Server melalui Hotspot Server Wizard.


        5. Jangan lupa interface yang dipakai sebagai hotspot interface adalah masing-masing interface bridge yang sebelumnya sudah dibuat.


        6. Masuk tab Server Profiles --> Silakan ganti nama profile nya sesuai dengan kegunaannya.



        7. Kita juga bisa integrasikan kedua Hotspot Server Profile dengan User Manager via RADIUS. Silakan baca Tutorialnya disini Cara Setting User Manager dengan Hotspot Mikrotik.


        8. Jika kita ga pakai User Manager, kita bisa gunakan user managemen bawaan hotspot nya. Silakan tambahkan User Hotspot nya pada tab Users.


        9. Disini kita bisa memilih user tersebut mau dimasukkan ke Server Hotspot mana. Apakah user untuk ruang rapat atau untuk pegawai kantor, atau juga bisa untuk kedua server (all).

        10. Sekarang silakan dicoba konek ke masing-masing access point hotspot.

        11. Halaman login hotspot yang muncul untuk kedua Hotspot Server itu sama. Jika Anda mau mengganti Halaman Login Hotspotnya, silakan baca Tutorial nya disini : Cara Mengganti Halaman Login Hotspot Mikrotik.

        Jadi, setiap user yang konek ke Access Point Hotspot Kantor akan mendapatkan IP Address 192.168.20.0/24 sedangkan user yang konek ke AP Hotspot Ruang Rapat akan mendapatkan IP Address 192.168.10.0/24. 

        Dengan begini akan lebih mudah me-manage Hotspot nya dan alokasi IP address nya juga lebih banyak. 

        Kalau Anda mau membuat lebih dari 2 Hotspot Server silakan sesuaikan saja dengan kebutuhan.
        Semoga bermanfaat :)