Tampilkan postingan dengan label Failover. Tampilkan semua postingan
Tampilkan postingan dengan label Failover. Tampilkan semua postingan

Minggu, 07 Juni 2015

Bagaimana cara menggabungkan sekaligus menambahkan koneksi dari 2 ISP yang berbeda menjadi 1 dan jika salah satu putus link tidak down? Pertanyaan ini lah yang akan kita cari jawabannya dan kita ulas di Tutorial Mikrotik Indonesia kali ini.

Pada Tutorial Mikrotik kali ini, saya menggunakan 2 koneksi Internet dari 2 ISP yang berbeda.
ISP 1 = Three mobile broadband (USB Modem) --> port usb1
IP Address : Dynamic

ISP 2 = Telkomsel Flash (Android Tethering) --> port wlan1
IP Address : 192.168.43.1

Perangkat yang saya gunakan adalah Mikrotik RB751U-2HND. Perangkat ini memiliki 5 Port ethernet, 1 wlan, dan 1 port USB. Ketiga port ini akan kita gunakan untuk membangun sistem Dual ISP + Failover.

Disini saya coba menggunakan USB Modem sebagai koneksi ke ISP Three, dan wlan1 untuk koneksi dari HP Android ke ISP Telkomsel. Jika anda ingin menggunakan port ethernet saja atau port lainnya silakan dapat Anda sesuaikan sendiri setingan di tutorial ini.

Interface yang digunakan :
1. ppp-out --> koneksi ke ISP1
2. wlan1 --> koneksi ke ISP 2
3. ether2 --> koneksi ke client

Langsung saja ke Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover berikut ini :

1. Sebelum mulai, saya sarankan untuk me-reset Mikrotik Anda ke konfigurasi awal, agar tidak terjadi error setelah konfigurasi.
2. Masuk ke Mikrotik via Winbox --> Aktifkan interface wlan1 dan ppp-out.
3. Setting ppp-out dengan konfigurasi :
- Name : TRI
- APN : 3 data
- Phone : *99#
- username : 3data
- password : 3data
4. Setting wlan1 koneksikan dengan Android Tethering --> ganti nama wlan1 menjadi TSEL.
5. Buat DHCP Client untuk wlan1 (TSEL) --> IP --> DHCP Client --> Add
6. Tambahkan IP Address untuk ether2
7. Buat DHCP Server untuk ether2
8. Buat Mangle dengan script berikut. Silakan sesuaikan dengan nama interface yang anda gunakan :
/ip firewall mangle
add action=mark-connection chain=input in-interface=TSEL new-connection-mark=\
    ISP2_Conn
add action=mark-connection chain=input in-interface=TRI new-connection-mark=\
    ISP1_Conn
add action=mark-routing chain=output connection-mark=ISP1_Conn \
    new-routing-mark=to_ISP1 passthrough=no
add action=mark-routing chain=output connection-mark=ISP2_Conn \
    new-routing-mark=to_ISP2 passthrough=no
add chain=prerouting dst-address=10.85.187.58 in-interface=ether2
add chain=prerouting dst-address=192.168.43.0/24 in-interface=ether2
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=ether2 new-connection-mark=ISP1_conn \
    per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=ether2 new-connection-mark=ISP2_conn \
    per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=ISP1_conn \
    in-interface=ether2 new-routing-mark=to_ISP1
add action=mark-routing chain=prerouting connection-mark=ISP2_conn \
    in-interface=ether2 new-routing-mark=to_ISP2
9. Buat NAT untuk kedua ISP tersebut dengan Script berikut :
/ip firewall nat
add action=masquerade chain=srcnat comment="NAT ISP1" \
    out-interface=TRI
add action=masquerade chain=srcnat comment="NAT ISP2" \
    out-interface=TSEL

10. Buat Route kedua ISP untuk Failover :
/ip route
add check-gateway=ping distance=1 gateway=TRI routing-mark=to_ISP1
add check-gateway=ping distance=1 gateway=192.168.43.1 routing-mark=to_ISP2
add check-gateway=ping distance=1 gateway=TSEL
add check-gateway=ping distance=1 gateway=TRI

11. Setingan Selesai. Coba koneksi dengan bandwidth test menggunakan speedtest.net.
 

12. Coba download test menggunakan IDM.


Bagi anda yang masih bingung dengan Tutorial Mikrotik ini, silakan lihat Video Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover berikut ini :

Rabu, 18 Juni 2014

Membatasi koneksi internet di kantor terutama pada jam kerja kantor dapat dilakukan dengan menggunakan Mikrotik. Ada beberapa cara yang dapat digunakan untuk membatasi koneksi internet di Kantor dengan Mikrotik. Disini saya akan coba share Cara Membatasi Internet Jam Kantor dengan Mikrotik yang pernah saya pasang di kantor. Topologi nya seperti ini :


Sistem yang saya buat yaitu dengan membatasi akses ke situs-situs sosial media, porno, video streaming, dll pada saat jam kerja (08.00 - 12.00 & 13.30 - 16.00). Untuk detail nya sebagai berikut :

Membatasi akses :
Jam kerja pagi (08.00 � 12.00)

Membuka akses :
Jam istirahat (12.00 � 13.30)

Membatasi akses :
Jam kerja siang (13.30 � 16.00)

Membuka akses :
Jam luar kerja (16.00 � 08.00)
Pembatasan ini dimaksudkan agar karyawan dapat memanfaatkan waktu nya pada saat jam kerja untuk mengerjakan pekerjaan nya bukan untuk hal yang lain.  

Untuk membangun sistem ini, saya menggunakan beberapa tools di Mikroik dan juga bantuan dari DNS external yaitu OpenDNS dan Nawala. Disini saya menggunakan perangkat Mikrotik RB 951Ui-2Hnd yang memiliki port USB sehingga bisa menggunakan modem USB sebagai jalur internet cadangan (untuk failover).
Secara umum konfigurasi yang dilakukan adalah sebagai berikut :

1. Mengatur konfigurasi IP Address untuk jaringan Wi-Fi dan LAN pada mikrotik.
2. Menambahkan konfigurasi NTP (Network Time Protocol) Server untuk sinkronisasi waktu supaya mikrotik dapat berkerja tepat waktu. Ini sangat penting supaya script dapat dieksekusi tepat waktu.  Untuk konfigurasi NTP nya bisa lihat di gambar berikut atau bisa baca di artikel ini : Apa itu NTP? Setting NTP Client di Mikrotik


3. Konfigurasi jaringan internet di Mikrotik. Pastikan koneksi internet sudah jalan di Mikrotik. Untuk memastikannya silakan ping ke Google.com
4. Setting interface wireless mikrotik untuk share koneksi internet melalui Wi-Fi.

5. Menambahkan konfigurasi DNS Server dari OpenDNS dan Nawala sebagai filter dan memblokir konten berbahaya. Tutrorial nya silakan baca disini : Cara Mudah Memblokir Situs-situs Dewasa dengan DNS di Mikrotik


6. OpenDNS dapat digunakan untuk memfilter situs berbahaya dan memblokir akses ke situs tertentu sepeti social media, video streaming, dan lain - lain. Sementara untuk DNS Nawala hanya memblokir akses ke situs berbahaya.
7. OpenDNS digunakan saat jam kerja. DNS Nawala digunakan diluar jam kerja. Pengaturan nya menggunakan Script & Scheduller. Seting inilah yang akan dibahas pada artikel ini.

8. Mengaktifkan fitur Web Proxy untuk mempercepat koneksi internet (cache) dan memonitor konten yang diakses client. Silakan baca tutorial nya disini : Cara Membuat Transparent Proxy Mikrotik
9. Menambahkan konfigurasi firewall mikrotik untuk keamanan. Ada beberapa konfigurasi firewall yang saya gunakan :



10. Menambahkan konfigurasi fail over, untuk menambah jalur akses internet cadangan (backup) menggunakan modem USB dan mengaktifkannya saat koneksi jalur utama mati. Silakan lihat tutorialnya disini :

Oke, kembali ke point nomor 7 di atas, disini saya akan bahas Script & Scheduller nya. Silakan simak step-by-step nya berikut ini :

11. Yang pertama, kita akan membuat Script dulu. Pada Winbox, masuk ke System --> Scripts. Ada beberapa Script yang akan kita buat seperti gambar berikut :


12. Untuk Script back2main dan failover digunakan untuk konfigurasi failover menggunakan jalur cadangan modem USB. Silakan lihat point nomor 10 di atas.

13. Script pertama yang kita buat yaitu script jam kerja. Script ini akan memberikan perintah ke Mikrotik untuk mengganti setingan DNS ke IP DNS nya OpenDNS, kemudian melakukan flush cache DNS. Script nya sebagai beriku (masukkan ke kolom Source)

/ip dns set servers=208.67.220.220,208.67.222.222
/ip dns cache flush

14. Script selanjutnya digunakan untuk mengganti IP DNS ke Nawala.

/ip dns set servers=180.131.144.144,180.131.145.145
/ip dns cache flush

15. Hari libur yaitu Sabtu dan Minggu koneksi internet tidak dibatasi, tetapi masih menggunakan DNS Nawala. Caranya dengan mematikan penjadwalan (Scheduler) yang nanti akan kita buat.

/system scheduler disable 0
/system scheduler disable 1
 

16. Ketika masuk lagi ke hari kerja yakni hari senin, maka aturan nya kembali seperti semula dengan pembatasan internet pada jam kerja. Caranya dengan mengaktifkan kembali scheduler nya.

/system scheduler enable 0
/system scheduler enable 1

17. Script yang sudah kita buat sebelumnya akan dijalankan secara otomatis berdasarkan waktu (jam). Pastikan anda membuat scheduler nya urutan nya sama seperti gambar berikut ini; supaya script pada point 15 dan 16 bisa berjalan.


18.  Buat scheduler untuk mengeksekusi script jam kerja (pagi). 
Name : Filter Jam Kerja Pagi
Start Date : Pilih tanggal kapan script akan mulai dieksekusi secara otomatis
Start Time : Jam berapa script akan dieksekusi
Interval : 1 hari
On Event : nama script yang dieksekusi (jam kerja)

19. Buat scheduler lagi untuk jam kerja sore yakni pukul 13.30 (sesuaikan jam nya dengan jam kantor anda). Lihat gambar berikut :


20. Ketika masuk jam istirahat, pegawai dapat mengakses social media, video streaming, dll kecuali web dan konten porno. Caranya dengan mengganti ke DNS Nawala. Buat scheduler pada jam 12.00 dengan script luar jam kerja (LJK).


21.  Ketika masuk jam pulang kerja, maka koneksi akan sama seperti pada jam istirahat. Disini diasumsikan jam pulang kantor pukul 16.00.


22. Pada hari libur (Sabtu & Minggu) script libur akan dieksekusi secara otomatis pada Jum'at malam pukul 23.59 dengan interval waktu 7 hari. Jadi script ini akan dieksekusi seminggu sekali yakni hari Jum'at malam. 
Jadi, Pastikan Start Date nya adalah hari jum'at


23. Pada hari senin koneksi akan kembali dibatasi secara otomatis dengan script senin yang akan dieksekusi pada senin dini hari pukul 00.00. lebih 50 detik dengan interval 7 hari.
Pastikan start date nya hari senin.


Sampai disini konfigurasi script dan scheduler sudah selesai. Jika setingan nya benar seperti di atas maka script nya akan berjalan dengan baik secara otomatis.

Oke sekian dulu tutorial Cara Membatasi Internet Jam Kantor dengan Mikrotik. Silakan dicoba, semoga berhasil, dan semoga bermanfaat :)

Kamis, 29 Mei 2014

Teknik Failover adalah suatu teknik jaringan dengan memberikan dua jalur koneksi atau lebih dimana ketika salah satu jalur mati, maka koneksi masih tetap berjalan dengan disokong oleh jalur lainnya. Teknik failover ini cukup penting ketika kita menginginkan adanya koneksi jaringan internet yang handal.

Tutorial Failover 2 Koneksi Internet di Mikrotik yang akan saya bahas kali ini sedikit spesial, karena bukan seperti failover yang biasanya. Jadi disini saya akan membuat jaringan internet dengan menggunakan 2 koneksi, yaitu koneksi utama menggunakan Fiber Optic dan koneksi cadangan dengan Modem USB. Secara umum topologi jaringannya seperti berikut :



Teknik failover yang akan saya gunakan kali ini adalah dengan membuat koneksi dari Fiber Optic sebagai Jalur utama dan ketika jalur utama mati (down) maka koneksi akan langsung pindah ke jalur cadangan. Dan jika koneksi utama kembali normal (up) maka koneksi akan kembali pindah ke jalur utama. Hal ini tidak dapat dilakukan dengan menggunakan teknik Failover biasa yang hanya menggunakan ping check gateway pada Route.

Untuk menerapkan teknik ini saya menggunakan perpaduan beberapa tools di Mikrotik, yakni Script, Netwatch, dan Check gateway pada Route. Oke langsung saja menuju Tutorial Failover 2 Koneksi Internet di Mikrotik. Disini saya tidak akan membahas caranya dari awal, tapi langsung ke inti cara failover nya. 

1. Pastikan kedua koneksi internet yang akan anda gunakan sudah berjalan dengan baik di Mikrotik.

2. Masuk ke System --> Script --> Add. Tambahkan 2 Script Mikrotik berikut :
Script Failover :
:if ([/ip route get [/ip route find comment="utama"] disabled]=yes) do={/ip route enable [/ip route find comment="utama"]} else={/ip route disable [/ip route find comment="utama"]}

Script kembali ke jalur utama :
:if ([/ip route get [/ip route find comment="utama"] disabled]=yes) do={/ip route enable [/ip route find comment="utama"]}

3. Buat rule Netwatch. Masuk ke Tools --> Netwatch --> Add. Buat dua rule berikut :
Netwatch Failover :
[Tab Host]
- Host : 8.8.8.8
- Interval : 00:00:03
- Timeout : 1000 ms
[Tab Down]
On Down : failover (sesuaikan dengan nama script nya)



Netwatch Kembali ke jalur utama :
[Tab Host]
- Host : 8.8.8.8
- Interval : 00:00:03
- Timeout : 1000 ms
[Tab Up]
On Up: back2main (sesuaikan dengan nama script nya)


4. Edit tabel routing mikrotik. Masuk ke IP --> Routes. Buat seperti gambar berikut ini :


Route untuk jalur utama :
Buat secara manual route untuk jalur utama dengan konfigurasi :
- Dst Address : 0.0.0.0/0
- Gateway : ether1 (pilih interface yang terhubung ke jalur utama)
- Distance : 1
- Check Gateway : ping
- Yang paling penting adalah buat comment. Klik menu Comment --> isikan : utama


Route untuk jalur cadangan :
Buat secara manual route untuk jalur utama dengan konfigurasi :
- Dst Address : 0.0.0.0/0
- Gateway : smartfren (pilih interface yang terhubung ke jalur cadangan)
- Distance :2
- Yang paling penting adalah buat comment. Klik menu Comment --> isikan : cadangan

Route untuk ping netwatch :
Buat route untuk jalur ping Netwatch dengan konfigurasi :
- Dst Address : 0.0.0.0/0
- Gateway : ether1 (pilih interface yang terhubung ke jalur utama)
- Distance : 1

5. Konfigurasi sudah selesai. Sekarang coba cek konfigurasi nya sudah bisa berjalan dengan baik apa belum. Caranya dengan lakukan ping ke google, dan coba matikan koneksi jalur utama. Jika konfigurasi benar, maka ping akan timeout untuk beberapa saat kemudian reply lagi yang mengindikasikan kalau failover bekerja. Hidupkan lagi koneksi jalur utama, maka jika konfigurasi benar, koneksi akan langsung berpindah kembali ke jalur utama.

Untuk lebih jelasnya silakan lihat video Failover Mikrotik berikut ini :
 

Oke, cukup sekian Tutorial Failover 2 Koneksi Internet di Mikrotik ini. Silakan dicoba dan semoga bermanfaat :)