Tampilkan postingan dengan label Bandwidth Management. Tampilkan semua postingan
Tampilkan postingan dengan label Bandwidth Management. Tampilkan semua postingan

Kamis, 28 Juli 2016

Membatasi/Limit Bandwidth pada Hotspot Mikrotik merupakan hal yang sangat perlu dilakukan. Mengingat Wireless Hotspot dapat diakses oleh siapa saja yang memiliki hak akses, sehingga agar terciptanya keadilan dan kesejahteraan yang merata pada segenap user hotspot diperlukan Pembatasan Bandwidth Hotspot Mikrotik.

Metode Pembatasan Bandwidth Hotspot Mikrotik ada 2 :

    - Built-in limiter merupakan metode Limit Bandwidth Hotspot Mikrotik yang menggunakan parameter rate-limit di server-profile untuk melimit total traffic dari jaringan hotspot sedangkan jika ingin limit per user bisa menggunakan rate-limit di user-profile. Built-in Limitation dilakukan secara otomatis dan mudah tetapi tidak memungkinkan melakukan implementasi HTB.
      - Custom limitation merupakan metode Limit Bandwidth Hotspot Mikrotik yang menggunakan parameter Incoming-packet-mark dan outgoingpacket-mark pada user-profile. Dengan menggunakan Custom Limitation anda bisa melakukan implementasi HTB dan melakukan limitasi berdasarkan kriteria koneksi yang lebih beragam. 

        Cara Membatasi/Limit Bandwidth User Hotspot Mikrotik menggunakan Built-in Limiter :

        Rate Limit pada Hotspot Server Profile

        Rate Limit pada Hotspot Server Profile

        Penggunaan Rate Limit pada hotspot server profile ini, secara otomatis akan membatasi total traffic pada jaringan Hotspot Mikrotik. Pada gambar di atas, besarnya rate limit yang diset pada jaringan hotspot adalah sebesar 2M/2M, yang berarti 2 Mbps untuk total traffic upload dan 2 Mbps untuk total traffic Download pada jaringan hotspot tersebut. Perlu diketahui bahwa dengan menggunakan metode ini user yang di bypass melalui IP Binding Hotspot juga ter-limit.

        Rate Limit pada Hotspot User Profile

        Rate Limit pada Hotspot User Profile

        Penggunaan Rate Limit yang pada hotspot user profile ini, akan membatasi total traffic secara otomatis yang bisa dicapai oleh masing-masing client hotspot yang berada pada satu group. Client hotspot yang terhubung dalam jaringan hotspot, mendapatkan total traffic yang bisa dicapai sebesar 512 kbps untuk download dan 512 kbps untuk upload.

        Hasil penggunaan Built-in bandwidth limiter Hotspot Mikrotik


        Cara Membatasi/Limit Bandwidth User Hotspot Mikrotik menggunakan Custom Limitation :


        Parameter Incoming Packet Mark dan Outgoing Packet Mark didefinisikan untuk melakukan penandaan (marking) traffic dari user didalam group tersebut. Incoming Packet Mark melakukan marking traffic upload dan Outgoing Packet Mark melakukan marking traffic download.

        Penggunaan incoming dan Outgoing Packet Mark Hotspot Mikrotik


        Firewall mangle akan terbentuk secara otomatis dan dinamis, dimana bertugas melakukan marking packet traffic dari client yang masuk di dalam group (profile). Dynamic Marking ini dilakukan di chain Hotspot. 

        Mangle rule otomatis terbentuk dari incoming dan outgoing packet mark

        Penambahan Rule Jump dari Built-in Chain ke chain hotspot diperlukan supaya traffic dari user dapat dibaca di firewall.

        /ip firewall mangle add chain=prerouting action=jump jump-target=hotspot
        /ip firewall mangle add chain=postrouting action=jump jump-target=hotspot

        Jika di asumsikan network yang digunakan adalah network NAT. Mark-Connection harus dibuat berdasarkan mark packet dynamic dari profile atau dari chain hotspot.
        /ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=koneksi_hotspot passthrough=yes packetmark=hs1-in

        Selanjutnya Mark-Packet bisa dibuat supaya bisa diimplementasikan atau dilimit trafficnya.
        /ip firewall mangle add chain=prerouting action=mark-packet newpacket-mark=paket_hotspot passthrough=no connectionmark=koneksi_hotspot
        /ip firewall mangle add chain=postrouting action=mark-packet newpacket-mark=paket_hotspot passthrough=no connectionmark=koneksi_hotspot
        Rule Mangle yang digunakan pada Custom Bandwidth Hotspot Mikrotik


        Setelah mark packet dari traffic group1 sudah dibuat maka limitasi bandwidth bisa dibuat di Queue.

        Setting pada Queue Tree

        Membuat Queue Tree untuk Traffic Download global, kita contohkan menggunakan Max Limit 2 Mb.

        Queue Tree Global Download Hotspot Mikrotik

        Kemudian membuat Queue Tree turunan nya khusus untuk download via Hotspot menggunakan Limit At 1 Mb dan Max Limit 2Mb.
         

        Queue Tree Download Hotspot Mikrotik

        Buat Queue Tree yang sama untuk traffic upload nya, sehingga menjadi seperti gambar berikut :

        Hasil Penggunaan Queue Tree pada Hotspot Mikrotik

        Selanjutnya Queue Tree Hotspot Mikrotik ini bisa kita kembangkan untuk membuat managemen bandwidth yang lebih complex, misalnya dengan menggunakan PCQ, dsb.

        Minggu, 07 Juni 2015

        Bagaimana cara menggabungkan sekaligus menambahkan koneksi dari 2 ISP yang berbeda menjadi 1 dan jika salah satu putus link tidak down? Pertanyaan ini lah yang akan kita cari jawabannya dan kita ulas di Tutorial Mikrotik Indonesia kali ini.

        Pada Tutorial Mikrotik kali ini, saya menggunakan 2 koneksi Internet dari 2 ISP yang berbeda.
        ISP 1 = Three mobile broadband (USB Modem) --> port usb1
        IP Address : Dynamic

        ISP 2 = Telkomsel Flash (Android Tethering) --> port wlan1
        IP Address : 192.168.43.1

        Perangkat yang saya gunakan adalah Mikrotik RB751U-2HND. Perangkat ini memiliki 5 Port ethernet, 1 wlan, dan 1 port USB. Ketiga port ini akan kita gunakan untuk membangun sistem Dual ISP + Failover.

        Disini saya coba menggunakan USB Modem sebagai koneksi ke ISP Three, dan wlan1 untuk koneksi dari HP Android ke ISP Telkomsel. Jika anda ingin menggunakan port ethernet saja atau port lainnya silakan dapat Anda sesuaikan sendiri setingan di tutorial ini.

        Interface yang digunakan :
        1. ppp-out --> koneksi ke ISP1
        2. wlan1 --> koneksi ke ISP 2
        3. ether2 --> koneksi ke client

        Langsung saja ke Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover berikut ini :

        1. Sebelum mulai, saya sarankan untuk me-reset Mikrotik Anda ke konfigurasi awal, agar tidak terjadi error setelah konfigurasi.
        2. Masuk ke Mikrotik via Winbox --> Aktifkan interface wlan1 dan ppp-out.
        3. Setting ppp-out dengan konfigurasi :
        - Name : TRI
        - APN : 3 data
        - Phone : *99#
        - username : 3data
        - password : 3data
        4. Setting wlan1 koneksikan dengan Android Tethering --> ganti nama wlan1 menjadi TSEL.
        5. Buat DHCP Client untuk wlan1 (TSEL) --> IP --> DHCP Client --> Add
        6. Tambahkan IP Address untuk ether2
        7. Buat DHCP Server untuk ether2
        8. Buat Mangle dengan script berikut. Silakan sesuaikan dengan nama interface yang anda gunakan :
        /ip firewall mangle
        add action=mark-connection chain=input in-interface=TSEL new-connection-mark=\
            ISP2_Conn
        add action=mark-connection chain=input in-interface=TRI new-connection-mark=\
            ISP1_Conn
        add action=mark-routing chain=output connection-mark=ISP1_Conn \
            new-routing-mark=to_ISP1 passthrough=no
        add action=mark-routing chain=output connection-mark=ISP2_Conn \
            new-routing-mark=to_ISP2 passthrough=no
        add chain=prerouting dst-address=10.85.187.58 in-interface=ether2
        add chain=prerouting dst-address=192.168.43.0/24 in-interface=ether2
        add action=mark-connection chain=prerouting dst-address-type=!local \
            in-interface=ether2 new-connection-mark=ISP1_conn \
            per-connection-classifier=both-addresses-and-ports:2/0
        add action=mark-connection chain=prerouting dst-address-type=!local \
            in-interface=ether2 new-connection-mark=ISP2_conn \
            per-connection-classifier=both-addresses-and-ports:2/1
        add action=mark-routing chain=prerouting connection-mark=ISP1_conn \
            in-interface=ether2 new-routing-mark=to_ISP1
        add action=mark-routing chain=prerouting connection-mark=ISP2_conn \
            in-interface=ether2 new-routing-mark=to_ISP2
        9. Buat NAT untuk kedua ISP tersebut dengan Script berikut :
        /ip firewall nat
        add action=masquerade chain=srcnat comment="NAT ISP1" \
            out-interface=TRI
        add action=masquerade chain=srcnat comment="NAT ISP2" \
            out-interface=TSEL

        10. Buat Route kedua ISP untuk Failover :
        /ip route
        add check-gateway=ping distance=1 gateway=TRI routing-mark=to_ISP1
        add check-gateway=ping distance=1 gateway=192.168.43.1 routing-mark=to_ISP2
        add check-gateway=ping distance=1 gateway=TSEL
        add check-gateway=ping distance=1 gateway=TRI

        11. Setingan Selesai. Coba koneksi dengan bandwidth test menggunakan speedtest.net.
         

        12. Coba download test menggunakan IDM.


        Bagi anda yang masih bingung dengan Tutorial Mikrotik ini, silakan lihat Video Tutorial Mikrotik : Menggabungkan & Menambahkan Koneksi 2 ISP + Failover berikut ini :

        Jumat, 24 Oktober 2014

        Shared Bandwidth Management Mikrotik digunakan untuk mengalokasikan bandwidth tiap client dengan rate yang bervariasi tergantung aktif tidaknya client lain dalam jaringan. Dengan menggunakan metode ini maka jika salah satu client tidak aktif (offline) maka alokasi bandwidth nya akan diberikan ke client lain.

        Melanjutkan skenario sebelumnya tentang Simple Bandwidth Management Mikrotik, kita misalkan ada 2 client yaitu client 1 dan client 2 masing-masing akan mendapatkan alokasi bandwidth 256kbps/256kbps. Sehingga total bandwitdh mikrotik untuk 2 client tersebut adalah 512kbps/512kbps. Jika client 1 tidak menggunakan alokasi bandiwidthnya, maka jatah bandwidthnya akan diberikan kepada client yang lain, sehingga client 2 akan mendapatkan alokasi bandwidth maksimum.

        Konfigurasi yang pertama kali dilakukan adalah konfigurasi untuk membatasi penggunaan bandwidth untuk kedua client sekaligus. 


        Konfigurasi ini juga berfungsi sebagai pembatasan bandiwidth parent. Perintah yang dapat digunakan adalah sebagai berikut :
        queue simple add name=limit-all target=10.10.10.0/24 max-limit=512000/512000

        Selanjutnya dibuat konfigurasi untuk membatasi pemakaian bandwidth setiap client dengan menggunakan konfigurasi sebelumnya sebagai parent. Perintah yang dapat digunakan adalah sebagai berikut :

        queue simple add name=limit-1 target=10.10.10.1 max-limit=512000/512000 limit-at=256000/256000 parent=limit-all

        queue simple add name=limit-2 target=10.10.10.2 max-limit=512000/512000 limit-at=256000/256000 parent=limit-all

        Sekarang kita coba cek dengan memonitor alokasi bandwidth kedua client menggunakan tool torch mikrotik.

        1. Ketika kedua client aktif menggunakan seluruh alokasi bandwidth (512kb)


        2. Ketika salah satu client tidak aktif (offline), bandwidth akan diberikan ke client lain.


        Demikianlah Tutorial Mikrotik Indonesia tentang Shared Bandwidth Management Mikrotik Menggunakan Simple Queue. Silakan anda coba dan sesuaikan sendiri dengan kondisi jaringan yang digunakan.
        Simple Bandwidth Management Mikrotik digunakan untuk mengalokasikan bandwidth Mikrotik secara sederhana (simple) menggunakan menu Simple Queue Mikrotik. Dengan menggunakan static bandwidth control maka alokasi bandwidth mikrotik untuk masing-masing client akan tetap. Misalnya client 1 akan mendapatkan alokasi bandwidth yaitu sebesar 256kbps/256kbps, begitu juga dengan client 2.

        Perintah yang dapat digunakan adalah sebagai berikut :
        queue simple add name=limit-1 target-addresses=10.10.10.10 max-limit=256000/256000

        queue simple add name=limit-2 target-addresses=10.10.10.20 max-limit=256000/256000
        Atau bisa juga menggunakan Winbox, masuk ke menu Queues --> Simple Queues



        Pengujian atau monitoring terhadap aktifitas bandwidth yang sudah dibatasi dapat dilihat dengan menggunakan menu torch, dan interface yang dimonitor adalah interface ether2, karena interface ini yang terhubung ke jaringan lokal. Perintah yang digunakan sebegai berikut :
        tool torch ether2 src-address=10.10.10.0/24

        Atau bisa menggunakan Winbox, masuk ke menu Tools --> Torch


        Demikianlah Tutorial Mikrotik Indonesia tentang Simple Bandwidth Management Mikrotik Menggunakan Simple Queue. Silakan anda coba dan sesuaikan sendiri dengan kondisi jaringan yang digunakan.

        Semoga bermanfaat :)

        Selasa, 12 Agustus 2014

        Pengaturan dan managemen Bandwidth di Mikrotik tidak dapat lepas dari fitur Queue. Ada dua jenis Queue yang dapat digunakan di Mikrotik, yaitu Simple Queue dan Queue Tree. Untuk penjelasan tentang Simple Queue sudah pernah saya bahas disini :
        Cara Membatasi (Limit) Bandwidth Mikrotik dengan Simple Queue
        Nah, kali ini kita akan membahas Penjelasan Queue Tree & PCQ (Per Connection Queue) serta Penerapannya di Mikrotik.

        Queue Tree 

        Queue Tree berfungsi untuk mengimplementasikan fungsi yang lebih komplex dalam limit bandwidth pada mikrotik dimana penggunaan packet mark nya memiliki fungsi yang lebih baik. Digunakan untuk membatasi satu arah koneksi saja baik itu download maupun upload. Secara umum Queue Tree ini tidak terlihat berbeda dari Simple Queue.

        Perbedaan yang bisa kita lihat langsung yaitu hanya dari sisi cara pakai atau penggunaannya saja. Dimana Queue Simple secara khusus memang dirancang untuk kemudahan konfigurasi sementara Queue Tree dirancang untuk melaksanakan tugas antrian yang lebih kompleks dan butuh pemahaman yang baik tentang aliran trafik.


        Beberapa Perbedaan Simple Queue dan Queue Tree :
        1. Queue Simple
        • Memiliki aturan urutan yang sangat ketat, antrian diproses mulai dari yang paling atas sampai yang paling bawah.
        • Mengatur aliran paket secara bidirectional (dua arah).
        • Mampu membatasi trafik berdasarkan alamat IP.
        • Satu antrian mampu membatasi trafik dua arah sekaligus (upload/download).
        • Jika menggunakan Queue Simple dan Queue Tree secara bersama-sama, Queue Simple akan diproses lebih dulu dibandingkan Queue Tree.
        • Mendukung penggunaan PCQ sehingga mampu membagi bandwidth secara adil dan merata.
        • Bisa menerapkan antrian yang ditandai melalui paket di /firewall mangle.
        • Mampu membagi bandwidth secara fixed.
        • Sesuai namanya, pengaturannya sangat sederhana dan cenderung statis, sangat cocok untuk admin yang tidak mau ribet dengan traffic control di /firewall mangle.
        2. Queue Tree
        • Tidak memiliki urutan, setiap antrian akan diproses secara bersama-sama.
        • Mengatur aliran paket secara directional (satu arah)
        • Membutuhkan pengaturan /firewall mangle untuk membatasi trafik per IP.
        • Membutuhkan pengaturan /firewall mangle terlebih dahulu untuk membedakan trafik download dan upload.
        • Dinomorduakan setelah Queue Simple.
        • Mendukung penggunaan PCQ sehingga mampu membagi bandwidth secara adil dan merata.
        • Pengaturan antrian murni melalui paket yang ditandai di /firewall mangle.
        • Mampu membagi bandwidth secara fixed.
        • Lebih fleksibel dan butuh pemahaman yang baik di /firewall mangle khususnya tentang traffic control.

        http://mikrotikindo.blogspot.com/

        Penjelasan beberapa argumen di Queue Tree :
        1. Parent : berguna untuk menentukan apakah queue yang dipilih bertugas sebagai child queue
        Ada beberapa pilihan default di parent queue tree yang biasanya digunakan untuk induk queue:
        - Global-in :
        Mewakili semua input interface pada umumnya. Maksudnya disini interface yang menerima input data/trafik sebelum difilter seperti trafik upload
         - Global-out :
        Mewakili semua output interface pada umumnya. Maksudnya disini interface yang mengeluarkan output data/trafik yang sudah difilter seperti trafik download
        - Global-total :
        Mewakili semua input dan output interface secara bersama, dengan kata lain merupakan penyatuan dari global-in dan global-out.                                  
         - <interface name>: ex: lan atau wan :
        Mewakili salah satu interface keluar. Maksudnya disini hanya trafik yang keluar dari interface ini yang akan diqueue.

        2. Packet Mark : Digunakan untuk menandai paket yang sudah ditandai di /ip firewall mangle.

        3. Priority ( 1 s/d 8) : Digunakan untuk memprioritaskan child queue dari child queue lainnya. Priority tidak bekerja pada induk queue. Child Queue yang mempunyai priority satu (1) akan mencapai limit-at lebih dulu dari pada child queue yang berpriority (2).

        4. Queue Type : Digunakan untuk memilih type queue yang bisa dibuat secara khusus dibagian queue types
        - Limit At : Bandwidth minimal yang diperoleh oleh target/ip yang diqueue
        - Max Limit : Bandwidth maksimal yang bisa dicapai oleh target/ip yang diqueue.
        - Burst limit : Bandwidth maksimal yang bisa dicapai oleh target/ip yang diqueue ketika burst sedang aktif
        - Burst time : Periode waktu dalam detik, dimana  data Rate rata-rata dikalkulasikan.
        - Burst Threshold : Digunakan ketika data Rate dibawah nilai burst threshold maka burst diperbolehkan.Ketika data Rate sama dengan nilai burst threshold burst dilarang. Untuk mengoptimalkan burst nilai burst threshold harus diatas nilai Limit At dan dibawah nilai
        Max Limit.


        PCQ (Per Connection Queuing) 

        Digunakan untuk mengenali arah arus dan digunakan karena dapat membagai bandwidth secara adil, merata dan masif. PCQ pada mikrotik digunakan bersamaan dengan fitur Queue, baik Simple Queue maupun Queue Tree.

        Untuk lebih mudah memahami konsep PCQ, silakan simak analogi berikut ini :
        Saya punya 10 PC yang akan saya bagikan bandwidth maksimal 1 Mb dan bandwidth minimal tiap PC 256 kb. Jika hanya satu PC saya yang online maka dia akan dapat BW max 1 Mb, namun jika ada dua PC yang online BW dibagi 2, dan seterusnya hingga 10 dengan pembagian bandwidth yang merata.

        Nah, untuk membuat konfigurasi seperti ini, saya harus membuat 1 rule parent Queue dan 10 rule child Queue untuk tiap client. Untuk kondisi sekarang yang hanya 10 PC it's ok, ga masalah. Namun bayangkan jika PC nya ada 100? 200? Gimana kalau yang saya kelola adalah jaringan WiFi Hotspot dengan client yg ga tentu jumlah nya? Apa iya saya harus membuat ratusan rule untuk tiap client? Capek dongg..

        Oleh karena itu, saya dapat gunakan fitur PCQ ini untuk melakukan manajemen bandwidth secara massive kepada semua client secara besar-besaran. Dengan menggunakan PCQ ini, walaupun jumlah client tidak tentu dan sangat banyak, kita hanya perlu membuat satu atau dua konfigurasi Queue. Enak kan?


        Penjelasan Beberapa Argumen di PCQ :

        PCQ Classifier berfungsi mengklasifikasikan arah koneksi, Misalnya jika Classifier yang digunakan adalah src-address pada Local interface, maka aliran pcq akan menjadi koneksi upload. Begitu juga dgn dst-address akan menjadi pcq download.

        PCQ rate berfungsi untuk membatasi bandwidth maksimum yang bisa didapatkan. Dengan memasukkan angka pada rate ini (default: 0) maka maksimal download yang akan didapatkan per IP akan dibatasi mis. 128k (kbps).



        Limit berfungsi untuk membatasi jumlah koneksi paralel yang diperkenankan bagi tiap IP. artinya bila kita meletakkan nilai 50, maka cuma 50 koneksi simultan yang bisa didapat oleh 1 IP address (baik itu source / destination).

        Total Limit adalah total keseluruhan koneksi paralel yang diperkenankan untuk seluruh ip addresss (baik itu source ataupun destination).

        Contoh penerapan PCQ dan Queue Tree di Mikrotik :

        Menggabungkan fitur Layer7 dan packet marking menggunakan mangle untuk menandai file yang biasa di download untuk kemudian dibatasi bandwidth download menggunakan Queue Tree + PCQ. Sehingga tiap client akan mendapatkan koneksi limited download dan unlimited browsing.

        http://mikrotikindo.blogspot.com/2014/01/tutorial-mikrotik-limited-download-unlimited-browsing.html

        Tutorial Bandwidth Mikrotik : Limited Download, Unlimited Browsing Menggunakan Layer 7

        Referensi :
        http://learningbytutz.blogspot.com/2012/03/memahami-queue-tree-dan-pcq-di-mikrotik.html
        http://www.alkomp.net/2014/03/perbedaan-queue-simple-dan-queue-tree.html

        Minggu, 20 April 2014

        Membagi Bandwidth internet secara sederhana berdasarkan interface menggunakan Mikrotik. Hal ini yang akan kita bahas kali pada artikel ini. Sebelum saya lanjutkan, saya sarankan untuk membaca artikel sebelumnya tentang Cara Membatasi (Limit) Bandwidth Mikrotik dengan Simple Queue Mikrotik.

        Oke, langsung saja kita mulai. Jadi kali ini kita akan membuat pembagian bandwidth secara sederhana berdasarkan interface yang digunakan. Untuk lebih jelasnya silakan lihat topologi jaringannya berikut ini :


        Bandwidth internet yang saya gunakan adalah seperti berikut ini :


        Koneksi Internet dari ISP 3 dengan Bandwidth 4 Mbps (Download) dan 1 Mbps (Upload).
        Nah, dari koneksi internet itu, saya akan membagi bandwidth nya menjadi 3 dibagi per interface. Jadi disini saya menggunakan 4 interface ether.
        -> interface ether1 : koneksi ke internet (DHCP Client)
        -> interface ether2 : koneksi ke client 1
        -> interface ether3 : koneksi ke client 2
        -> interface ether4 : koneksi ke client 3

        Masing-masing interface ether akan dikasih bandwidth
        Download : 4 Mb/3 = 1333 Kb
        Upload : 1 Mb/3 = 333 Kb

        Oke, kita mulai langkah-langkah Cara Membagi Bandwidth Sederhana di Mikrotik :
        1. Pastikan Mikrotik anda sudah bisa terhubung ke Internet (Seting DHCP Client, DNS, Firewall Masquerde, IP Address, dll).

        2. Seting IP address untuk masing-masing interce yang tehubung ke client :
        --> ether2 : 10.10.10.1/24
        --> ether3 : 10.10.20.1/24
        --> ether4 : 10.10.30.1/24


        3. Buat DHCP Server untuk masing-masing client, masuk menu IP --> DHCP Server --> DHCP Setup
        (Jika anda ingin konfigurasi IP client secara manual point ini bisa dilewati)


        4. Untuk Membagi Bandwidth, masuk ke menu Queues --> Simple Queues --> Buat rule baru

        [Tab General]
        --> Beri nama rule nya
        --> Target : ether2 atau 10.10.10.0/24
        --> Max limit :
        ---> Target Upload : 333k
        ---> Target Download : 1333k


        [Tab Advanced]
        --> Limit At :
        ---> Target Upload : 333k
        ---> Target Download : 1333k
        Untuk membuat rule pada interface selanjutnya, tinggal klik saja tombol Copy terus ganti nama dan target nya supaya lebih cepat.


         5. Kalo setingan sudah beres, sekarang kita coba tes dengan melakukan Bandwidth test pada Client, dan hasilnya adalah sebagai berikut :

        Hasilnya hampir sama seperti yang sudah kita seting sebelumnya yakni :
        Bandwidth 1190 Kb (Download) dan 333 Kb (Upload)

        Sekarang pertanyaan nya, kenapa pembagian nya dibuat per interface? Karena itu adalah permintaan klien saya :D. Waktu saya di Makassar, saya diminta oleh Polda Sulsel untuk membagi bandwidth internet menjadi tiga menggunakan Mikrotik RB750. Masing-masing dibuat sama rata per interface karena mau digunakan untuk koneksi Video Conference dengan Mabes Polri. Sekalian saya bantu seting juga video conference nya. Sedikit curhat boleh ya :D

        Oke, sekian saja tutorial Cara Membagi Bandwidth Sederhana di Mikrotik. Semoga bermanfaat :)

        Senin, 27 Januari 2014

        Cara Menghitung Burst untuk simple queue Mikrotik. Sebelumnya saya pernah membahas tentang burst di artikel ini Tenik Burst Bandwidth pada Mikrotik. Pada kesempatan ini, saya akan coba bahas lagi tentang burst bandwidth yaitu Cara Menghitung dan Menggunakan Burst pada Simple Queue Mikrotik.



        Lama waktu ideal untuk mengakses sebuah situs harusnya tidaklah lebih dari 10 hitungan jari atau 10 detik. Hal ini diperlukan untuk memberikan kenyamanan bagi user dalam melakukan aktivitas browsing. Maka tak ada salahnya kita memberikan aliran Bandwidth yang cukup besar pada 10 detik pertama, dan selanjutnya kita batasi untuk memberikan download file yang biasanya lebih dari 10 detik.

        Burst pada simple Queue bertujuan untuk mengijinkan aliran data tertinggi untuk beberapa periode waktu. Fasilitas ini berguna untuk membatasi pemakaian bandwidth secara berlebihan dan terus menerus bagi user-user yang rakus akan bandwidth. Hanya pada beberapa periode waktu tertentu sajalah user mendapatkan jatah b/w yang cukup besar.

        Pada fitur Burst terdapat beberapa variabel yang harus ditentukan nilainya, antara lain Burst Limit, Burst Threshold dan Burst Time. Yang perlu diperhatikan adalah, jika rata-rata aliran data lebih rendah dari �Burst Threshold�, Burst akan secara aktual mengikuti �Burst Limit"�, dimana setiap detik router akan menghitung rata-rata data yang dicapai melalui burst time yang terakhir.
        Click here to enlarge
        Click here to enlarge

        Penulis menggunakan rumus tersendiri yang di buat di excel

        Dimana :

        N = Interval time

        X = Burst Limit

        Y = Burst Threshold

        Z = Burst Time

        M = Max Limit

        Rumus : Y = (X*N) / Z

        M = 4/3 * Y

        Contoh :

        X = 1024 kbps

        N = 10 detik

        Z = 40 s

        Y = (1024*10) / 40 = 256 kbps

        Maka di dapat Burst Threshold = 256 kbps

        M = 4/3 * 256 = 342 kbps

        Maka di dapat Max Limit = 342kbps

        Jika di set maka hasil yang di dapat :

        Click here to enlarge

        Click here to enlarge

        Click here to enlarge

        Dari grafik di atas di liat waktu buka website bandwidth langsung naik dari 256 kbps ke 1024 kbps trus makin lama makin turun ke max limit 342 kbps. Teknis ini dapat menghemat bandwidth agar tidak banyak user mengambil bandwidth untuk download.

        Untuk limit at dapat di hitung dengan cara misalkan ada 6 komputer. Bandwidth yang kita punya max 1 Mbps (1024 kbps) maka bagi 6 (1024/6) = 170 kbps kita set limit at tidak boleh lebih dari 170 kbps atau kasih rata-rata = 128 kbps. Sehingga user minimal dapat bandwidth 128 kbps.

        Agar lebih mudah menghitung nya, silakan gunakan Burst Calculator dengan excel yang dapat anda download disini.


        sumber:
        http://beta.forummikrotik.com/general-networking/18183-menghitung-burst-threshold-untuk-simple-queue.html

        Sabtu, 18 Januari 2014

        Limited Download dan Unlimited Browsing adalah salah satu teknik manajemen Bandwidth yang efektif untuk membagi bandwidth secara adil. Karena, jika bandwidth download tidak dibatasi, maka akan menggangu kecepatan internet pengguna lain dalam satu jaringan. Akibatnya, jika ada beberapa pengguna yang melakukan download apalagi menggunakan IDM, maka pengguna lain yang cuma browsing tidak kebagian bandwidth.

        Nah, untuk mengatasi hal ini, maka teknik Limited Download dan Unlimited Browsing ini kita terapkan. Pada Mikrotik, teknik ini bisa dilakukan dengan banyak cara. Salah satu cara yang simpel dan efektif adalah menggunakan filter Layer 7 Protocol. Yang belum tau apa itu Layer 7 Protocol, silakan baca disini.


        1. Buat daftar extensi file yang masuk filter download di Layer 7 protocol. Silakan copy dan paste script berikut ke Terminal Mikrotik kemudian tekan enter. Jika ekstensi file nya dirasa kurang banyak silakan ditambahkan sendiri.

        /ip firewall layer7-protocol

        add comment="" name=donlotan regexp="^.*get.+\\.(exe|rar|zip|7z|cab|asf|mov|wmv\

        |mpg|mpeg|mkv|avi|flv|pdf|wav|rm|mp3|mp4|ram|rmvb|dat|daa|iso|nrg|bin|vcd|\

        mp2|3gp|mpe|qt|raw|wma|ogg|doc|deb|tar|bzip|gzip|gzip2|0[0-9][0-9]).*\$"

        2. Buat Firewall Mangle untuk menandai paket yang mau dilimit. Silakan copy paste juga script berikut ini ke Terminal dan tekan enter. Kita cukup menggunakan 1 Mangle saja, simpel kan? :D

        /ip firewall mangle

        add action=mark-packet chain=forward comment=Donlotan disabled=no \

        layer7-protocol=donlotan new-packet-mark=paket-donlot passthrough=no protocol=tcp



        3. Silakan cek apakah script tadi berhasil dieksekusi menjadi setingan atau tidak.
        Cek Setingan Layer 7 protocol : IP --> Firewall --> Layer7 Protocol

        Cek Setingan Mangle : IP --> Firewall --> Mangle




        4. Selanjutnya buat limit bandwidth nya dengan Queue. 
        Queue Type : Masuk ke Queue --> Queue Types --> add
        - Beri nama limit dl
        - Kind : pcq
        - Rate : 64k (silakan sesuaikan dengan keinginan berapa max speed download nya)
        jika diisi 64k, maksudnya membatasi kecepatan download 64 kbps dibagi 8 --> 8 KB/s
        jika ingin lebih tinggi bisa saja diisi 256k sehingga throughput : 256/8 = 32 KB/s
        NB : ingat 1 byte = 8 bit
        Silakan diisi sesuai keinginan anda.
        - Setingan lainnya biarkan saja, lihat gambar berikut ini :



        Queue Tree : masuk ke Queue --> Queue Tree --> add
        - Beri nama : Limit Download
        - Parent : global (Router OS saya versi 6, cuma ada satu parent global)
        - Packet Marks : paket-donlot
        - Queue Type : limit dl
        - Max Limit : 64k (Sesuaikan dengan kebutuhan anda)
        Anda juga bisa memanfaatkan fitur Limit At, silakan baca disini untuk penjelasan lebih lengkap :


        5. Setingan selesai. Jadi setingan di atas membatasi bandwidth download sebesar 64kbps = 8KB/s.

        6. Coba cek apakah setingan sudah benar dengan melakukan tes download file :
        Sebelum menggunakan Limit Download :


        Setelah menggunakan Limit Download :

        Oke, demikianlah Tutorial Bandwidth Mikrotik : Limited Download, Unlimited Browsing Menggunakan Layer 7 Protocol. Silakan anda praktekan sesuai dengan kondisi jaringan anda. Selamat mencoba :)

        Referensi :
        http://komputersinau.blogspot.com/2012/10/limitid-download-unlimited-browsing.html

        Rabu, 18 September 2013

        Pernahkah anda mengalami ketika sedang menggunakan internet untuk browsing speed nya kenceng banget, tapi ketika dipake buat download kenceng nya Cuma di awal aja selama beberapa detik, setelah itu jadi lemot banget kecepatan download nya. Ada yang pernah mengalami hal tersebut? 

        Ya, itulah yang disebut dengan teknik Burst Bandwidth. Fitur burst ini tidak hanya terdapat pada Mikrotik saja, tapi penggunaannya lebih mudah jika menggunakan Mikrotik. Burst adalah fitur yang menungkinkan client mendapatkan alokasi bandwidth lebih dari alokasi bandwidth maksimum yang disediakan dalam selang waktu tertentu. 

        Hal ini sangat menguntungkan bagi client yang hanya menggunakan internet untuk aktivitas browsing, karena kecepatan dalam browsing akan bertambah, walaupun hanya beberapa detik saja. Namun hal ini akan membuat proses pembukaan halaman web lebih cepat. 

        Lain halnya dengan client yang menggunakan untuk download, seperti yang sudah saya ceritakan di awal. Client yang melakukan aktivitas download hanya akan mendapatkan tambahan alokasi bandwidth melebihi bandwidth maksimum di awal proses download saja. Jika proses burst telah selesai maka kecepatanya akan kembali seperti semula, sesuai dengan alokasi bandwidth yang disediakan. 

        Untuk lebih jelasnya anda dapat lihat di gambar berikut ini :

        Dari gambar tersebut saya kasih contoh ya, misalnya saya punya koneksi internet dari ISP dengan bandwidth 8Mb, kemudian semua client saya kasih alokasi bandwidth 240Kb. Jadi normal nya kalo tanpa burst client akan dapat bandwidth stabil 240Kb. Kemudian saya terapkan teknik Burst ini dengan memberikan semua alokasi bandwidth yang ada yakni 8Mb kepada semua client namun hanya dalam waktu 3 detik saja. Setelah 3 detik bandwidth kembali seperti semula 240Kb.

        Untuk dapat menggunakan teknik burst ini terdapat beberapa perhitungan yang harus kita perhatikan agar burst nya sesuai yang kita harapkan. Namun untuk perhitungan dan cara penggunaan nya pada Mikrotik akan kita bahas pada kesempatan lain. So, stay tune on blog Tutorial Mikrotik Indonesia :D

        Semoga informasi tentang Tenik Burst Bandwidth pada Mikrotik ini bermanfaat :)